Linux Foundation Logo
Zowe Logo

Zowe Response to Recent Industry Vulnerabilities

Published: October 2026 | Zowe Security Workgroup

Overview of Vulnerabilities

Recommended Actions

1. Upgrade Node.js Runtimes

Upgrading Node.js addresses both the eMudhra root store distrust and the Brotli (node2shell) vulnerability. Node.js versions earlier than 26.12.1, 24.22.1, and 22.23.4 are vulnerable. Users of Zowe CLI and server-side Node.js components should upgrade their Node.js runtimes to the patched versions immediately:

For users of Zowe Explorer, update your VS Code environment to 1.143.1 or later.

2. Update Java / JVM Environments

Ensure that Java runtime environments (JRE/JDK) powering the Zowe API Mediation Layer and other Java services on z/OS have received the latest security updates from IBM's Java distribution to ensure root certificates and trust stores remain secure.

3. Inspect Custom Truststores and Keyrings

If you have any eMudhra certificate authorities in your z/OS keyrings or custom enterprise truststores, remove them and restart Zowe.